C# バージョン 8.0 で開発する

C# で開発中にエラー「再帰的パターン’ は C# 7.3 では使用できません。8.0 以上の言語バージョンをお使いください。」が出た。

ここで気づく。Visual Studio 2019 という最新環境で開発しているにも関わらず、言語のバージョンが古いとは。8.0 で開発するにはプロジェクトファイルに <LangVersion>8.0</LangVersion> を追加する必要がある。